package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*[0,9]{8}`)
var str = `aaaaaa_20200217`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}