$re = '/.*[0,9]{8}/';
$str = 'aaaaaa_20200217';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);