$re = '/^(?!.*\.d\.ts$).*\.ts$/m';
$str = 'some-string.ts
some-string.d.ts
some-stringd.ts
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);