re = /^(?!.*\.d\.ts$).*\.ts$/m
str = 'some-string.ts
some-string.d.ts
some-stringd.ts
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end