package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\@(.*?)\>`)
var str = `From: <sip:39988444@10.25.148.58>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}