$re = '/\@(.*?)\>/m';
$str = 'From: <sip:39988444@10.25.148.58>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);