package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?[1-9][0-9]*$`)
var str = `-90
90
-0
-00
1
-1
0
00
+2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}