$re = '/\bpe[^\s]+/mi';
$str = 'Peter Piper picked a peck of amazing pickeled peppers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);