re = /\bpe[^\s]+/mi
str = 'Peter Piper picked a peck of amazing pickeled peppers'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end