const regex = /^([a-zA-Z0-9_.+-])+\@(([a-zA-Z_+-])+\.)+([a-zA-Z]{2,4})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9_.+-])+\\@(([a-zA-Z_+-])+\\.)+([a-zA-Z]{2,4})?$', '')
const str = `aarti.kumari@igt22**.22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}