$re = '/^([a-zA-Z0-9_.+-])+\@(([a-zA-Z_+-])+\.)+([a-zA-Z]{2,4})?$/';
$str = 'aarti.kumari@igt22**.22';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);