package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<Account Id="*">`)
var str = `<Account Id=">
<Account Id="">
<Account Id=""">
<Account Id="123456789012">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}