// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<Account Id="*">"#).unwrap();
let string = "<Account Id=\">
<Account Id=\"\">
<Account Id=\"\"\">
<Account Id=\"123456789012\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}