const regex = /(?: |\G)\d\B\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: |\\G)\\d\\B\\K', 'g')
const str = `123 a123 1234567 b123`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);