import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^( *)( *)( *)(['.-])((?!\\4)(?4)+?)((?!\\4|\\5)(?4)++)\\1\\3whale\n"
+ "(?=.(.))\\6.\\7\\4(?!\\4|\\6)([_\\/])\\3(?!(?11))\\8\\2(?=\\2)\\3\\1_((?=\\4+.).\\5(?!\\6)\\5)(?!.?')\\7\\4\n"
+ "(?=.\\7)\\6.([,`])\\3{2}(?=.((?!\\8)[_\\/])\\11)\\Q(_\\E.\\4{2}(?!\\.)\\5((?!\\10)(?10)(?!\\4+|\\5|\\6))\\1\\3{3}(\\\\)\n"
+ "(\\3{3})\\13\\2{2}\\1{1}\\3+(?<=\\S {10})\\4\\1\\3\\|\n"
+ "\\1(?=\\12)(?12)(?!`,)\\10\\4(\\11{2})\\4\\14\\10\\15\\9\\8\n"
+ "\\14{2}(?=\\6)['-]\\4(?<!-)\\11\\8\\11\\4\\6\\11\\15\\.-|(?!)";
final String string = " .'- whale\n"
+ "-::./ / _.'':.\n"
+ "-:, (__..'` \\\n"
+ " \\ . |\n"
+ "`,.__. ,__.''/\n"
+ " -._/_.-___.-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}