#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*://|/.*"
Local $sString = "https://domen.site.ru/podsait/03285926/#2412747495" & @CRLF & _
"http://www.site.ru/site/24722305" & @CRLF & _
"https://www.domen.site.ru/site/247493215/site" & @CRLF & _
"site.ru"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")