using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*://|/.*";
string input = @"https://domen.site.ru/podsait/03285926/#2412747495
http://www.site.ru/site/24722305
https://www.domen.site.ru/site/247493215/site
site.ru";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}