#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\.([\w_]+))"
Local $sString = " <style>" & @CRLF & _
" .tblGenFixed td {" & @CRLF & _
" padding: 0 3px;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" white-space: normal;" & @CRLF & _
" letter-spacing: 0;" & @CRLF & _
" word-spacing: 0;" & @CRLF & _
" background-color: #fff;" & @CRLF & _
" z-index: 1;" & @CRLF & _
" border-top: 0px none;" & @CRLF & _
" border-left: 0px none;" & @CRLF & _
" border-bottom: 1px solid #CCC;" & @CRLF & _
" border-right: 1px solid #CCC;" & @CRLF & _
" }" & @CRLF & _
" .dn {" & @CRLF & _
" display: none" & @CRLF & _
" }" & @CRLF & _
" .tblGenFixed td.s0 {" & @CRLF & _
" background-color: #000000;" & @CRLF & _
" font-family: arial, sans, sans-serif;" & @CRLF & _
" font-size: 120.0%;" & @CRLF & _
" font-weight: bold;" & @CRLF & _
" font-style: normal;" & @CRLF & _
" color: #ffffff;" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" text-align: left;" & @CRLF & _
" vertical-align: bottom;" & @CRLF & _
" direction: auto-ltr;" & @CRLF & _
" white-space: normal;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" border-top: 1px solid #CCC;" & @CRLF & _
" border-right: ;" & @CRLF & _
" border-bottom: ;" & @CRLF & _
" border-left: 1px solid #CCC;" & @CRLF & _
" }" & @CRLF & _
"</style>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")