import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.([\\w_]+))";
final String string = " <style>\n"
+ " .tblGenFixed td {\n"
+ " padding: 0 3px;\n"
+ " overflow: hidden;\n"
+ " white-space: normal;\n"
+ " letter-spacing: 0;\n"
+ " word-spacing: 0;\n"
+ " background-color: #fff;\n"
+ " z-index: 1;\n"
+ " border-top: 0px none;\n"
+ " border-left: 0px none;\n"
+ " border-bottom: 1px solid #CCC;\n"
+ " border-right: 1px solid #CCC;\n"
+ " }\n"
+ " .dn {\n"
+ " display: none\n"
+ " }\n"
+ " .tblGenFixed td.s0 {\n"
+ " background-color: #000000;\n"
+ " font-family: arial, sans, sans-serif;\n"
+ " font-size: 120.0%;\n"
+ " font-weight: bold;\n"
+ " font-style: normal;\n"
+ " color: #ffffff;\n"
+ " text-decoration: none;\n"
+ " text-align: left;\n"
+ " vertical-align: bottom;\n"
+ " direction: auto-ltr;\n"
+ " white-space: normal;\n"
+ " overflow: hidden;\n"
+ " border-top: 1px solid #CCC;\n"
+ " border-right: ;\n"
+ " border-bottom: ;\n"
+ " border-left: 1px solid #CCC;\n"
+ " }\n"
+ "</style>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}