using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:more|most)\s+\w*ly(*SKIP)(*F)|\w*ly";
string input = @"fastly onffly fly incomprehensibly totaly happily
lily sly more happily
most seriously";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}