$re = '/^(?=[^\/]*\/[^\/]*\/[^\/]*$).*/m';
$str = 'example.com/test/testurl
example.com/test/test-url
example.com/test/testurl/content
example.com/test/test-url/content';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;