re = /^(?=[^\/]*\/[^\/]*\/[^\/]*$).*/m
str = 'example.com/test/testurl
example.com/test/test-url
example.com/test/testurl/content
example.com/test/test-url/content'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result