using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"amazon\.com/dp/(\w{10})";
string input = @"u'http://www.amazon.com/dp/B003T0G9GM/ref=wl_it_dp_v_nS_ttl/177-5611794-0982247?_encoding=UTF8&colid=SBGZJRGMR8TA&coliid=I205LCXDIRSLL3'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}