re = /amazon\.com\/dp\/(\w{10})/
str = 'u\'http://www.amazon.com/dp/B003T0G9GM/ref=wl_it_dp_v_nS_ttl/177-5611794-0982247?_encoding=UTF8&colid=SBGZJRGMR8TA&coliid=I205LCXDIRSLL3\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end