$re = '/.*\V?(\d\S+)\.tar\.xz/m';
$str = 'https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);