// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\V?(\d\S+)\.tar\.xz").unwrap();
let string = "https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}