#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "re.match('(.*).*(\[.*\]).*(\[.*\])', '')"
Local $sString = "The.Last.Ship.S02E13.1080p.WEB-DL.DD5.1.H.264-BLiN.mkv*" & @CRLF & _
"The.Librarians.US.S02E05.720p.HDTV.x264-FLEET.mkv*" & @CRLF & _
"The.Librarians.US.S02E06.720p.HDTV.x264-0SEC.mkv*" & @CRLF & _
"The.Librarians.US.S02E08.720p.HDTV.x264-0SEC.mkv*" & @CRLF & _
"The.Librarians.US.S02E09.720p.HDTV.x264-0SEC.mkv*" & @CRLF & _
"The.Librarians.US.S02E10.720p.HDTV.x264-KILLERS.mkv*" & @CRLF & _
"tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-101.mkv*" & @CRLF & _
"tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-102.mkv*" & @CRLF & _
"tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-103.mkv*" & @CRLF & _
"Warehouse.13.S04E20.720p.HDTV.x264-EVOLVE.mkv*" & @CRLF & _
"Warehouse.13.S05E01.720p.HDTV.x264-REMARKABLE.mkv*" & @CRLF & _
"warehouse.13.s05e02.720p.hdtv.x264-killers.mkv*" & @CRLF & _
"warehouse.13.s05e03.720p.hdtv.x264-killers.mkv*" & @CRLF & _
"warehouse.13.s05e04.720p.hdtv.x264-2hd.mkv*" & @CRLF & _
"Warehouse.13.S05E05.720p.HDTV.X264-DIMENSION.mkv*" & @CRLF & _
"Warehouse.13.S05E06.720p.HDTV.X264-DIMENSION.mkv*" & @CRLF & _
"White.Collar.S04E15.The.Original.720p.WEB-DL.DD5.1.h.264-NTb.mkv*" & @CRLF & _
"White.Collar.S04E16.PROPER.720p.HDTV.x264-EVOLVE.mkv*" & @CRLF & _
"White.Collar.S05E01.At.What.Price.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E02.Out.of.the.Frying.Pan.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"white.collar.s05e03.720p.hdtv.x264-killers.mkv*" & @CRLF & _
"White.Collar.S05E04.Controlling.Interest.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E05.Master.Plan.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E06.Ice.Breaker.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E06.Ice.Breaker.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*" & @CRLF & _
"White.Collar.S05E07.Quantico.Closure.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E07.Quantico.Closure.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*" & @CRLF & _
"White.Collar.S05E08.720p.HDTV.x264-IMMERSE.mkv*" & @CRLF & _
"White.Collar.S05E08.720p.HDTV.x264-IMMERSE-thumb.jpg*" & @CRLF & _
"White.Collar.S05E09.No.Good.Deed.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E09.No.Good.Deed.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*" & @CRLF & _
"White.Collar.S05E10.Live.Feed.720p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S05E10.Live.Feed.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*" & @CRLF & _
"White.Collar.S05E11.720p.HDTV.x264-REMARKABLE.mkv*" & @CRLF & _
"White.Collar.S05E11.720p.HDTV.x264-REMARKABLE-thumb.jpg*" & @CRLF & _
"White.Collar.S05E12.REPACK.720p.HDTV.x264-KILLERS.mkv*" & @CRLF & _
"White.Collar.S05E13.720p.HDTV.x264-REMARKABLE.mkv*" & @CRLF & _
"White.Collar.S06E01.Borrowed.Time.1080p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S06E02.Return.to.Sender.1080p.WEB-DL.DD5.1.H.264-NTb.mkv*" & @CRLF & _
"White.Collar.S06E03.720p.HDTV.x264-KILLERS.mkv*" & @CRLF & _
"White.Collar.S06E04.720p.HDTV.x264-KILLERS.mkv*" & @CRLF & _
"White.Collar.S06E05.720p.HDTV.x264-KILLERS.mkv*" & @CRLF & _
"White.Collar.S06E06.720p.HDTV.X264-DIMENSION.mkv*" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")