import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "re.match('(.*).*(\\[.*\\]).*(\\[.*\\])', '')";
final String string = "The.Last.Ship.S02E13.1080p.WEB-DL.DD5.1.H.264-BLiN.mkv*\n"
+ "The.Librarians.US.S02E05.720p.HDTV.x264-FLEET.mkv*\n"
+ "The.Librarians.US.S02E06.720p.HDTV.x264-0SEC.mkv*\n"
+ "The.Librarians.US.S02E08.720p.HDTV.x264-0SEC.mkv*\n"
+ "The.Librarians.US.S02E09.720p.HDTV.x264-0SEC.mkv*\n"
+ "The.Librarians.US.S02E10.720p.HDTV.x264-KILLERS.mkv*\n"
+ "tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-101.mkv*\n"
+ "tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-102.mkv*\n"
+ "tvs-csi-cyber-dd51-ded-dl-18p-ithd-avc-103.mkv*\n"
+ "Warehouse.13.S04E20.720p.HDTV.x264-EVOLVE.mkv*\n"
+ "Warehouse.13.S05E01.720p.HDTV.x264-REMARKABLE.mkv*\n"
+ "warehouse.13.s05e02.720p.hdtv.x264-killers.mkv*\n"
+ "warehouse.13.s05e03.720p.hdtv.x264-killers.mkv*\n"
+ "warehouse.13.s05e04.720p.hdtv.x264-2hd.mkv*\n"
+ "Warehouse.13.S05E05.720p.HDTV.X264-DIMENSION.mkv*\n"
+ "Warehouse.13.S05E06.720p.HDTV.X264-DIMENSION.mkv*\n"
+ "White.Collar.S04E15.The.Original.720p.WEB-DL.DD5.1.h.264-NTb.mkv*\n"
+ "White.Collar.S04E16.PROPER.720p.HDTV.x264-EVOLVE.mkv*\n"
+ "White.Collar.S05E01.At.What.Price.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E02.Out.of.the.Frying.Pan.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "white.collar.s05e03.720p.hdtv.x264-killers.mkv*\n"
+ "White.Collar.S05E04.Controlling.Interest.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E05.Master.Plan.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E06.Ice.Breaker.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E06.Ice.Breaker.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*\n"
+ "White.Collar.S05E07.Quantico.Closure.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E07.Quantico.Closure.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*\n"
+ "White.Collar.S05E08.720p.HDTV.x264-IMMERSE.mkv*\n"
+ "White.Collar.S05E08.720p.HDTV.x264-IMMERSE-thumb.jpg*\n"
+ "White.Collar.S05E09.No.Good.Deed.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E09.No.Good.Deed.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*\n"
+ "White.Collar.S05E10.Live.Feed.720p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S05E10.Live.Feed.720p.WEB-DL.DD5.1.H.264-NTb-thumb.jpg*\n"
+ "White.Collar.S05E11.720p.HDTV.x264-REMARKABLE.mkv*\n"
+ "White.Collar.S05E11.720p.HDTV.x264-REMARKABLE-thumb.jpg*\n"
+ "White.Collar.S05E12.REPACK.720p.HDTV.x264-KILLERS.mkv*\n"
+ "White.Collar.S05E13.720p.HDTV.x264-REMARKABLE.mkv*\n"
+ "White.Collar.S06E01.Borrowed.Time.1080p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S06E02.Return.to.Sender.1080p.WEB-DL.DD5.1.H.264-NTb.mkv*\n"
+ "White.Collar.S06E03.720p.HDTV.x264-KILLERS.mkv*\n"
+ "White.Collar.S06E04.720p.HDTV.x264-KILLERS.mkv*\n"
+ "White.Collar.S06E05.720p.HDTV.x264-KILLERS.mkv*\n"
+ "White.Collar.S06E06.720p.HDTV.X264-DIMENSION.mkv*\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}