package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.`)
var str = `notsudo:x:26:
sudo:x:27:foo,bar,baz
completelynotsudo:x:29:`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}