$re = '/./';
$str = 'notsudo:x:26:
sudo:x:27:foo,bar,baz
completelynotsudo:x:29:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);