$re = '/^[A-Z][a-z]*(?: [A-Z][a-z]*)*$/m';
$str = 'Fruits
fruits
United States
United states
A B C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);