re = /^[A-Z][a-z]*(?: [A-Z][a-z]*)*$/m
str = 'Fruits
fruits
United States
United states
A B C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end