$re = '/^(?:[^|]*[|]){2}([^|]*)/';
$str = '123|xx3|1x23|1x2x3|x123x|123x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);