$re = '/, *([^()]*)(?=\))/m';
$str = 'BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)
BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;