re = /, *([^()]*)(?=\))/m
str = 'BlockedMatch(XA, YB), Correlation(XA, QC), Correlation(YB, QC), Correlation(QC, YB)
BlockedMatch(XAYB), Correlation(XAQC), Correlation(YBQC), Correlation(QCYB)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result