re = /:\s+(?<executiontime>\S+)/m
str = 'OUT: IndexController.printHello - time taken: 519 ms"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end