use strict;
my $str = 'https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456';
my $regex = qr/^(?:(?<protocol>[^:/]+:))?(?::?\/\/)?(?:(?<user>[^/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\w._-]*))?(?::(?<port>\d*))?(?:(?<path>\/?[^?]*))?(?:(?<search>\?[^#]*))?(?:(?<hash>#.*))?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}