import re
regex = re.compile(r"{#include\s*([\w.]+)\s*}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("{#include header.html}\n"
" <header class=\"bg-gradient-to-r from-purple-700 to-indigo-800 shadow-lg w-full\">\n"
" <div class=\"max-w mx-auto px-4 sm:px-6 lg:px-8 py-6\">\n"
" <div class=\"flex flex-col items-center justify-between md:flex-row\">\n"
" <a href=\"/\">\n"
" <h1 class=\"mb-4 text-2xl font-bold text-white md:mb-0 md:text-3xl\">Header</h1>\n"
" </a>\n"
" <nav class=\"flex space-x-4\">\n"
" <a href=\"/\">\n"
" <a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">Home</a>\n"
" </a>\n"
" <a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">About</a>\n"
" <a href=\"#\" class=\"text-white transition duration-150 ease-in-out hover:text-purple-200\">Contact</a>\n"
" </nav>\n"
" </div>\n"
" </div>\n"
" </header>\n\n"
" <div class=\"flex flex-grow\">\n"
" <aside class=\"w-72 bg-gray-100 scrollable-column\">\n"
" <div class=\"p-6\">\n"
" <h2 class=\"mb-4 text-xl font-semibold text-gray-800\">Directories</h2>\n"
" {#each item in dirs}\n"
" <div class=\"mb-3\">\n"
" <a href=\"{item.link}\"\n"
" class=\"font-medium text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800\">{item.name}</a>\n"
" </div>\n"
" {/each}\n"
" </div>\n"
" </aside>\n\n"
" <main class=\"flex-grow bg-white scrollable-column\">\n"
" <div class=\"p-6 md:p-8\">\n"
" {#each item in files}\n"
" <div class=\"space-y-4\">\n"
" <div class=\"flex flex-col sm:flex-row border-b-2 border-gray-200 pb-4\">\n"
" <div class=\"w-full sm:w-[150px] h-[150px] border-2 border-black flex items-center justify-center overflow-hidden mb-4 sm:mb-0 flex-shrink-0\">\n"
" <a href=\"{item.link}\">\n"
" <img src=\"{item.image}\" alt=\"thumbnail\" class=\"w-full h-full object-cover\">\n"
" </a>\n"
" </div>\n"
" <div class=\"flex-grow pt-2 sm:pl-4\">\n"
" <h3 class=\"mb-2 text-xl font-semibold\">\n"
" <a href=\"{item.link}\"\n"
" class=\"text-indigo-600 transition duration-150 ease-in-out hover:text-indigo-800\">{item.name}</a>\n"
" </h3>\n"
" <p class=\"text-black text-sm -mt-2 mb-2\">{item.date}</p>\n"
" <p class=\"text-gray-600 text-lg\">{item.summery}</p>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" {/each}\n"
" </div>\n"
" </main>\n"
" </div>\n\n"
" <footer class=\"bg-gray-800 text-white\">\n"
" <div class=\"container mx-auto px-4 py-8\">\n"
" <div class=\"flex flex-col items-center justify-between md:flex-row\">\n"
" <div class=\"mb-4 text-2xl font-semibold md:mb-0\">Footer</div>\n"
" <div class=\"flex space-x-4\">\n"
" <a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Privacy</a>\n"
" <a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Terms</a>\n"
" <a href=\"#\" class=\"transition duration-150 ease-in-out hover:text-purple-300\">Contact</a>\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </footer>\n"
"{#include footer.html}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")