#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsm)^Date:\ (?P<date>.+?$)" & @CRLF & _
".+?" & @CRLF & _
"^From:\ (?P<sender>.+?$)" & @CRLF & _
".+?" & @CRLF & _
"^To:\ (?P<to>.+?$)" & @CRLF & _
".+?" & @CRLF & _
"^cc:\ (?P<cc>.+?$)" & @CRLF & _
".+?" & @CRLF & _
"^Subject:\ (?P<subject>.+?$)"
Local $sString = "Message-ID: <3490571.1075846143093.JavaMail.evans@thyme>" & @CRLF & _
"Date: Wed, 8 Sep 1999 08:50:00 -0700 (PDT)" & @CRLF & _
"From: steven.kean@enron.com" & @CRLF & _
"To: kelly.kimberly@enron.com" & @CRLF & _
"Subject: Re: India And The WTO Services Negotiation" & @CRLF & _
"Mime-Version: 1.0" & @CRLF & _
"Content-Type: text/plain; charset=us-ascii" & @CRLF & _
"Content-Transfer-Encoding: 7bit" & @CRLF & _
"X-From: Steven J Kean" & @CRLF & _
"X-To: Kelly Kimberly" & @CRLF & _
"X-cc: " & @CRLF & _
"X-bcc: " & @CRLF & _
"X-Folder: \Steven_Kean_Dec2000_1\Notes Folders\All documents" & @CRLF & _
"X-Origin: KEAN-S" & @CRLF & _
"X-FileName: skean.nsf" & @CRLF & _
"" & @CRLF & _
"fyi" & @CRLF & _
"---------------------- Forwarded by Steven J Kean/HOU/EES on 09/08/99 03:49 " & @CRLF & _
"PM ---------------------------" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Joe Hillings@ENRON" & @CRLF & _
"09/08/99 02:52 PM" & @CRLF & _
"To: Joe Hillings/Corp/Enron@Enron" & @CRLF & _
"cc: Sanjay Bhatnagar/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Terence H " & @CRLF & _
"Thorn/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Ashok " & @CRLF & _
"Mehta/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, John " & @CRLF & _
"Ambler/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Steven J Kean/HOU/EES@EES, " & @CRLF & _
"Jeffrey Sherrick/Corp/Enron@Enron " & @CRLF & _
"Subject: Re: India And The WTO Services Negotiation " & @CRLF & _
"" & @CRLF & _
"Sanjay: Some information of possible interest to you. I attended a meeting " & @CRLF & _
"this afternoon of the Coalition of Service Industries, one of the lead groups " & @CRLF & _
"promoting a wide range of services including energy services in the upcoming " & @CRLF & _
"WTO GATTS 2000 negotiations. CSI President Bob Vastine was in Delhi last week " & @CRLF & _
"and met with CII to discuss the upcoming WTO. CII apparently has a committee " & @CRLF & _
"looking into the WTO. Bob says that he told them that energy services was " & @CRLF & _
"among the CSI recommendations and he recalls that CII said that they too have " & @CRLF & _
"an interest." & @CRLF & _
"" & @CRLF & _
"Since returning from the meeting I spoke with Kiran Pastricha and told her " & @CRLF & _
"the above. She actually arranged the meeting in Delhi. She asked that I send " & @CRLF & _
"her the packet of materials we distributed last week in Brussels and London. " & @CRLF & _
"One of her associates is leaving for India tomorrow and will take one of " & @CRLF & _
"these items to Delhi. " & @CRLF & _
"" & @CRLF & _
"Joe" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Joe Hillings" & @CRLF & _
"09/08/99 11:57 AM" & @CRLF & _
"To: Sanjay Bhatnagar/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT" & @CRLF & _
"cc: Terence H Thorn/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Ashok " & @CRLF & _
"Mehta/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, John " & @CRLF & _
"Ambler/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Steven J Kean/HOU/EES@EES, " & @CRLF & _
"Jeffrey Sherrick/Corp/Enron@Enron (bcc: Joe Hillings/Corp/Enron)" & @CRLF & _
"Subject: India And The WTO Services Negotiation" & @CRLF & _
"" & @CRLF & _
"Sanjay: First some information and then a request for your advice and " & @CRLF & _
"involvment."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")