# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^Date:\ (?P<date>.+?$)
.+?
^From:\ (?P<sender>.+?$)
.+?
^To:\ (?P<to>.+?$)
.+?
^cc:\ (?P<cc>.+?$)
.+?
^Subject:\ (?P<subject>.+?$)
"""
test_str = ("Message-ID: <3490571.1075846143093.JavaMail.evans@thyme>\n"
"Date: Wed, 8 Sep 1999 08:50:00 -0700 (PDT)\n"
"From: steven.kean@enron.com\n"
"To: kelly.kimberly@enron.com\n"
"Subject: Re: India And The WTO Services Negotiation\n"
"Mime-Version: 1.0\n"
"Content-Type: text/plain; charset=us-ascii\n"
"Content-Transfer-Encoding: 7bit\n"
"X-From: Steven J Kean\n"
"X-To: Kelly Kimberly\n"
"X-cc: \n"
"X-bcc: \n"
"X-Folder: \\Steven_Kean_Dec2000_1\\Notes Folders\\All documents\n"
"X-Origin: KEAN-S\n"
"X-FileName: skean.nsf\n\n"
"fyi\n"
"---------------------- Forwarded by Steven J Kean/HOU/EES on 09/08/99 03:49 \n"
"PM ---------------------------\n\n\n"
"Joe Hillings@ENRON\n"
"09/08/99 02:52 PM\n"
"To: Joe Hillings/Corp/Enron@Enron\n"
"cc: Sanjay Bhatnagar/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Terence H \n"
"Thorn/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Ashok \n"
"Mehta/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, John \n"
"Ambler/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Steven J Kean/HOU/EES@EES, \n"
"Jeffrey Sherrick/Corp/Enron@Enron \n"
"Subject: Re: India And The WTO Services Negotiation \n\n"
"Sanjay: Some information of possible interest to you. I attended a meeting \n"
"this afternoon of the Coalition of Service Industries, one of the lead groups \n"
"promoting a wide range of services including energy services in the upcoming \n"
"WTO GATTS 2000 negotiations. CSI President Bob Vastine was in Delhi last week \n"
"and met with CII to discuss the upcoming WTO. CII apparently has a committee \n"
"looking into the WTO. Bob says that he told them that energy services was \n"
"among the CSI recommendations and he recalls that CII said that they too have \n"
"an interest.\n\n"
"Since returning from the meeting I spoke with Kiran Pastricha and told her \n"
"the above. She actually arranged the meeting in Delhi. She asked that I send \n"
"her the packet of materials we distributed last week in Brussels and London. \n"
"One of her associates is leaving for India tomorrow and will take one of \n"
"these items to Delhi. \n\n"
"Joe\n\n\n\n"
"Joe Hillings\n"
"09/08/99 11:57 AM\n"
"To: Sanjay Bhatnagar/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT\n"
"cc: Terence H Thorn/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Ashok \n"
"Mehta/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, John \n"
"Ambler/ENRON_DEVELOPMENT@ENRON_DEVELOPMENT, Steven J Kean/HOU/EES@EES, \n"
"Jeffrey Sherrick/Corp/Enron@Enron (bcc: Joe Hillings/Corp/Enron)\n"
"Subject: India And The WTO Services Negotiation\n\n"
"Sanjay: First some information and then a request for your advice and \n"
"involvment.")
matches = re.search(regex, test_str, re.VERBOSE | re.DOTALL | re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.