using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hel?lo[ -_]?world";
string input = @"helloworld
heloworld
hello world
helo world
hello-world
helo-world
hello_world
helo_world";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}