$re = '/hel?lo[ -_]?world/m';
$str = 'helloworld
heloworld
hello world
helo world
hello-world
helo-world
hello_world
helo_world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);