const regex = /<input type="hidden" name="_csrf-app" value="(.*?)">/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input type="hidden" name="_csrf-app" value="(.*?)">', 'gm')
const str = `<input type="hidden" name="_csrf-app" value="l2cTlLik-s91R_T-nQUYEhbsKThjj2RlUA0QfQlAj-7bXl3AzeKbu0Ilg9PYRmJwc7tNagv5EC9gfyQTRA7NjQ==">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}