$re = '/<input type="hidden" name="_csrf-app" value="(.*?)">/m';
$str = '<input type="hidden" name="_csrf-app" value="l2cTlLik-s91R_T-nQUYEhbsKThjj2RlUA0QfQlAj-7bXl3AzeKbu0Ilg9PYRmJwc7tNagv5EC9gfyQTRA7NjQ==">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);