#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<assign.*?>"
Local $sString = "<if VERSION="A1" || VERSION="A3" || VERSION="a2_%5C%22A3">" & @CRLF & _
"" & @CRLF & _
"<assign CTA="blue">" & @CRLF & _
"<assign CTA2="green">" & @CRLF & _
"<assign TEXT1="Hello%3Cbr/%3EWorld">" & @CRLF & _
"" & @CRLF & _
"<elseif attribute-name="A2">" & @CRLF & _
"" & @CRLF & _
"<assign CTA="red">" & @CRLF & _
"<assign CTA2="yellow">" & @CRLF & _
"<assign CTA3="brown">" & @CRLF & _
"<assign TEXT1="Click%20%3Ca%20href='https://example.com'%20style='text-decoration:none;color:#000000;'%3Ehere%3C/a%3E">" & @CRLF & _
"" & @CRLF & _
"</if>" & @CRLF & _
"" & @CRLF & _
"// condition 2" & @CRLF & _
"<if FOO_BAR="A4" || baz-biz="A5">" & @CRLF & _
"" & @CRLF & _
"<assign CTA="purple">" & @CRLF & _
"<assign CTA2="orange">" & @CRLF & _
"<assign TEXT1="Hi%20%3Cspan%20style='font-%20weight:bold;'%3EJohn%3C/span%3E" TEXT2="Hello%3Cbr/%3EWorld">" & @CRLF & _
"" & @CRLF & _
"</if>" & @CRLF & _
"" & @CRLF & _
"// condition 3" & @CRLF & _
"<if LANG="en_US">" & @CRLF & _
"" & @CRLF & _
"<assign TITLE="English">" & @CRLF & _
"" & @CRLF & _
"</if>"
Local $sSubst = "$&</assign>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)