using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<assign.*?>";
string substitution = @"$&</assign>";
string input = @"<if VERSION=""A1"" || VERSION=""A3"" || VERSION=""a2_%5C%22A3"">
<assign CTA=""blue"">
<assign CTA2=""green"">
<assign TEXT1=""Hello%3Cbr/%3EWorld"">
<elseif attribute-name=""A2"">
<assign CTA=""red"">
<assign CTA2=""yellow"">
<assign CTA3=""brown"">
<assign TEXT1=""Click%20%3Ca%20href='https://example.com'%20style='text-decoration:none;color:#000000;'%3Ehere%3C/a%3E"">
</if>
// condition 2
<if FOO_BAR=""A4"" || baz-biz=""A5"">
<assign CTA=""purple"">
<assign CTA2=""orange"">
<assign TEXT1=""Hi%20%3Cspan%20style='font-%20weight:bold;'%3EJohn%3C/span%3E"" TEXT2=""Hello%3Cbr/%3EWorld"">
</if>
// condition 3
<if LANG=""en_US"">
<assign TITLE=""English"">
</if>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}