$re = '/([\p{L}\p{N}_-]+)-\d+/u';
$str = '<if VERSION-1="A1" VERSION-17="A3">
<assign CTA="blue"></assign>
<assign CTA2="green"></assign>
<assign TEXT1="Hello%3Cbr/%3EWorld"></assign>
<elseif VERSION-147="A2">
<assign CTA="red"></assign>
<assign CTA2="yellow"></assign>
<assign CTA3="brown"></assign>
<assign TEXT1="Click%20%3Ca%20href=\'https://example.com\'%20style=\'text-decoration:none;color:#000000;\'%3Ehere%3C/a%3E"></assign>
</if>
// condition 2
<if VERSION-409="A4" VERSION-425="A5">
<assign CTA="purple"></assign>
<assign CTA2="orange"></assign>
<assign TEXT1="Hi%20%3Cspan%20style=\'font-%20weight:bold;\'%3EJohn%3C/span%3E"></assign>
</if>
// condition 3
<if LANG-618="en_US">
<assign TITLE="English"></assign>
</if>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;