# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\p{L}\p{N}_-]+)-\d+"
test_str = ("<if VERSION-1=\"A1\" VERSION-17=\"A3\">\n\n"
"<assign CTA=\"blue\"></assign>\n"
"<assign CTA2=\"green\"></assign>\n"
"<assign TEXT1=\"Hello%3Cbr/%3EWorld\"></assign>\n\n"
"<elseif VERSION-147=\"A2\">\n\n"
"<assign CTA=\"red\"></assign>\n"
"<assign CTA2=\"yellow\"></assign>\n"
"<assign CTA3=\"brown\"></assign>\n"
"<assign TEXT1=\"Click%20%3Ca%20href='https://example.com'%20style='text-decoration:none;color:#000000;'%3Ehere%3C/a%3E\"></assign>\n\n"
"</if>\n\n"
"// condition 2\n"
"<if VERSION-409=\"A4\" VERSION-425=\"A5\">\n\n"
"<assign CTA=\"purple\"></assign>\n"
"<assign CTA2=\"orange\"></assign>\n"
"<assign TEXT1=\"Hi%20%3Cspan%20style='font-%20weight:bold;'%3EJohn%3C/span%3E\"></assign>\n\n"
"</if>\n\n"
"// condition 3\n"
"<if LANG-618=\"en_US\">\n\n"
"<assign TITLE=\"English\"></assign>\n\n"
"</if>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.