const regex = /\.(jpe?g|bmp|png|JPE?G|BMP|PNG)(?:[\?\#].*)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(jpe?g|bmp|png|JPE?G|BMP|PNG)(?:[\\?\\#].*)?$', '')
const str = `file.akaka.sksks.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}