import Foundation
let pattern = ##"\.(jpe?g|bmp|png|JPE?G|BMP|PNG)(?:[\?\#].*)?$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"file.akaka.sksks.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}